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DESIGNING IN SOLIDWORKS 
 

Customised Tools for Design and Documentation of   
LIGO Parts, Assemblies and Drawings 

 
1.  INTRODUCTION 
 
This document serves to describe in detail the usage of a series of SolidWorks customised 
tools created by Mike Perreur-Lloyd and Calum Torrie. The document is written to be used in 
conjunction with a sister document1, which gives an initial outline of the customised tools and 
instruction on the downloading and integration of these from a central location to the users 
desktop. 
 
2.  BACKGROUND INFORMATION 
 
The document details how information can be attached to SolidWorks parts, assemblies and 
drawings to aid the production of consistent engineering drawings, bill of materials, drawing 
trees and materials lists.  
 
The Bill of Materials [BOM] and Drawing Tree are essential documents required by LIGO 
that follow all designed parts from manufacture through to assembly. The LIGO Mechanical 
Drawing Guidelines document2 indicates that it is also useful, when sending a drawing pack 
for manufacture, if the major assemblies have an overall BOM (a, so called, materials list). In 
past LIGO projects it was necessary to create all of these as separate documents in programs 
such as Word or Excel, however by implementing the SolidWorks ‘Bill of Materials’ function 
it is possible to produce the documents automatically.  
 
To help the automation of these, a LIGO Bill of Materials has been designed that is tailored to 
ensure that the information detailed in the Mechanical drawing guidelines is correctly 
tabulated. Alongside this, ‘Smart’ CAD templates, ‘Smart’ Data templates, and the 
Customised Toolbox have been developed to automate the creation of parts, assemblies and 
engineering drawings.  
 
By establishing an array of customised tools it becomes easier to standardise the information 
shown in every part, assembly, and engineering drawing, thus improving the quality of the 
documentation. And by automating the production of the supplementary documents through 
entering information during the design stage, we make time for other areas of the project. 
 
Following the description and explanation of the LIGO Customised Tools, a step-by-step 
tutorial provides an example of the procedures used to produce a part, an assembly and a 
mechanical drawing with a the BOM, Materials List or Indented Drawing tree. The tutorial is 
concluded by an example of how a file can be uploaded to the Caltech PDMWorks vault.  

                                                 
1 D030382 “An Introduction to the LIGO PDMWorks Vault and a Top-Level Summary of the Drawing & Data 
templates, Macros, Bill of Materials and Customised Toolbox created for SolidWorks”. 
2 E030350 “Mechanical Drawing Guidelines; D Coyne; available on the LIGO DCC”.  
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3.  PART PROPERTIES FOR THE BOM 
 

ITEM NO REQ. SPARE TOT. PART NUMBER DESCRIPTION MATERIAL 

        
    

  

            

 
The functions used in creating an
instruction on how to use these is co

T  FIGURE 1

 
3.1. Item Number Column 
 
3.1.1. Default Properties 
SolidWorks has a number of defaul
the Item number it will automatical
are entered into an assembly. Thes
added to a drawing. In some situa
them in an assembly drawing ther
new functions that will over-write th
 
3.1.2. Hidden Parts and Assemblie
In an assembly it is often necess
eventually used in the final system
jig; an extra mass; an angled bla
necessary to differentiate between
assembly. In this situation these sho
 

ALT:  ‘Alternative’, e.g. a
in a suspension ass
optimum height.  

REF: ‘Reference’, e.g. a
construction of the 
suspension and he
document.  

A/R: ‘AsRequired’, e.g. a
a suspension assem
situation an ‘extra m

 
All of the above component type
SolidWorks custom properties are
SolidWorks’ and further relayed in 
 
3.2. Required Column 
 
SolidWorks automatically calculat
entered an assembly. However, whe
built we need to be able to multipl
are having manufactured. Again thi
  he above table shows the LIGO Bill of
Materials column headers
 accurate Bill of Materials are outlined below. Further 
ntained in the appended Tutorial (Appendix 1).  

t settings to each of the columns in the BOM. In the case of 
ly choose an item number depending on the order that parts 
e are the same numbers shown when balloon numbers are 
tions, however, we need to call up parts without showing 
efore the we have designed the LIGO BOM with several 
e default information with a more customised form.  

s 
ary to have additional parts or sub-systems that are not 
, for example (in terms of a suspension prototype): a wire 
de clamp. In the bill of materials for an assembly it is 
 these components depending upon their usage in the 
uld be referred to as one of the following: 

n angled blade clamp. This component would only be used 
embly should a blade be deflecting above or beyond the 

 wire jig. This sub-assembly was used in the in the 
suspension assembly, however is not part of the assembled 
nce need not be displayed on the assembly drawing 

n extra mass. This part is only required should the optic of 
bly, once fully suspended, be hanging too high. In this 
ass’ or a number of ‘extra masses’ are added, as required.  

s are entered into the custom properties of a drawing. 
 explained in section 4, ‘Setting Custom Properties in 
the appended tutorial (see Appendix 1).  

es the quantity of each part from the number of parts 
n we need to specify that more than one assembly is to be 
y the automatic defaults by however many assemblies we 
s can be done in the Custom Properties:   
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REQ:  ‘Required’, the total number of parts required to build an assembly or a 
number of assemblies (not including spares). 

 
3.3. Spare Column 
 
Again SolidWorks has a default setting, that is: the number of Spares is equal to the number of 
parts (i.e. 10 parts made, 10 spares made). As it is likely that this will not be the requirement 
for all parts it is possible to override this setting using the function:  

 
SPARE:  If ‘Spare’ is entered in the custom properties along with the desired value, 

this will override the default.  
 
3.4. Total Column 
 
The ‘Total’ column is far more self-explanatory and is purely a sum of the ‘Required’ and 
‘Spare’, detailed above. No custom properties are set for ‘Total’.  
 
3.5. Material Column 
 
Material is a column that has no default value as it has been created specifically for use in the 
LIGO BOM. It is important to enter a material custom property for all parts as the BOM will 
be the sole place that this information will be contained (individual engineering drawing of 
parts do not show material). The number of character spaces in the Material column is limited 
so below are some examples of typical material acronyms.  
 
 300 SSTL:  300 Series Stainless Steel 
 6061-T6-Al:  6061-T6 Aluminium (US specification) 
 6082-T6-Al:  6082-T6 Aluminium (UK specification) 
 PEEK [NAT]:  PEEK natural or virgin grade 
 
3.6. Part Number Column 
 
The LIGO BOM is set up such that the seven-digit part number associated with the LIGO 
Document Control Centre (DCC), e.g. D020123, will automatically be picked up from the 
‘Summary Properties’ beside the heading ‘title’: 

e.g.  D020123:  Enter this number next to Title on the ‘Summary Properties of 
the part.  

 
 
 
3.7. Description Column 
 
Again the LIGO BOM has been set-up to automatically pick up part description from the 
Custom Properties: 

e.g.  Angled Blade Clamp:  Enter ‘description’ into the custom properties followed 
by the part name for this to link in to the BOM automatically.  
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4. CREATING A BILL OF MATERIALS, DRAWING TREE OR MATERIALS LIST 
 
To create a Bill of Materials (BOM), Drawing Tree or Materials List by using the 
LIGOBOM3, it is simply a matter of selecting the appropriate settings in the SolidWorks Bill 
of Materials function. All of these functions are available when a drawing (.slddrw) of an 
assembly is open. For example: 

FIGURE 2

By selecting any of the assembly views on the drawing sheet and then, from the Main Heading 
Toolbar, Insert>Bill of Materials (You will notice that this is only highlighted when your 
assembly view is highlighted) you will open up the. Bill of Materials function 
 
This will then prompt you to open up a BOM.xls file from a list of files in SolidWorks.  

Page 4 
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Once the LIGOBOM is located, the following window shall open up on your screen:  

FIGURE 3

 
And it is by using this interface that the selections can be made to tabulate a BOM, Drawing 
Tree or Materials List.  
 
4.1. General Notes  
 

• It is advisable for all tables that the first two boxes are left unchecked, i.e. Do not ‘Use 
Summary Information title as part number’ and Do not ‘Use the document’s note font 
when creating the table’. The LIGO BOM is set-up such that the font size in the excel 
spreadsheet will create a table with a width equal to the note box on the bottom right 
corner of a drawing sheet.  

• The ‘use table anchor point box’ and the ‘Add new items by extending top border of 
table’ should also be left unchecked 

 
4.2. Creating a Bill of Materials  
 
To create a bill of materials, the box that should be checked on the ‘Configuration’ area of the 
‘Bill of Materials Properties’ is:  

  
And on the ‘Contents’ area of the ‘Bill of Materials Properties’ uncheck ‘Display labels at top’ 
 

Page 5 



Advanced LIGO LIGO-T030143-03-D 

4.3. Creating a Indented Drawing Tree 
 
To create an Indented Drawing Tree, the important boxes that should be checked are:  

 
4.4. Creating a Materials List 
 
Creating a materials list is now very similar to creating a LIGO bill of material (Section 3.1) 
with exception ‘display labels at top’ should be checked. Where a Bill of Materials is used on 
every assembly and sub-assembly, a Materials List is used only on Major assemblies and 
generally created prior to a drawing package being sent out to tender.  
 
To create an Indented Drawing Tree, the following box should be checked:  

 And, to reiterate, ‘Display labels at top’ under the ‘Contents’ Tab should also be checked.  
 
4.5. Completing the Engineering Drawing 
 
Once the correct boxes are checked and OK pressed, a BOM table will appear on the Drawing 
sheet. It is likely, however, that none or very little information is shown at first. The reason for 
this is that the added functions - the equations from Excel - have not yet been solved. You can 
update these functions by double clicking the table (which triggers Excel to open and 
calculations to be done) and then by clicking back on the drawing sheet again, this will close.  
 
The Table can then 
be moved into 
position, above the 
Drawing sheets 
PART LIST title box, 
by simply dragging 
the table to this 
location (as shown in 
Figure 4)  
 FIGURE 4
 
 
All information in the Bill of Materials, Drawing Tree or Materials List can be either kept in 
the SolidWorks drawing sheets or copied to an Excel Spreadsheet for inclusion in another 
document. It is important to note that, to keep the information up-to-date, it is advisable that 
the tables remain in SolidWorks until a point where all drawings are finalised i.e. just prior to 
Manufacture. 
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5. SETTING CUSTOM PROPERTIES IN SOLIDWORKS 
 
SolidWorks custom properties are very useful as they encourage us to embed important 
information into the part, assembly and drawing files and more importantly this information 
can be then be linked to other SolidWorks tools such as the Bill of Materials function and the 
Drawing Sheet.  
 
The Custom and Summary Properties window can be opened by going File>Properties.  

FIGURE 5

 
5.1. Summary Properties 
 
The first window in File>Properties will show the Summary Properties. This area is like any 
Microsoft file where you can store useful information about the file and when it was created, 
etc. Although it is not a necessity to store information here it will is a good exercise to 
practice. By clicking the top ‘Custom’ Tab we can now begin editing the custom properties.  
 
5.2. Custom Properties 
 
This is the key area in which you can enter the important information that links to the Bill of 
Materials and Drawing sheet. As shown in Figure 5 (Right) above the information described 
earlier about Required, Spare, Material, etc can be entered here.  
 
In the case of Alternative, Reference and As Required parts these should be entered as follows 
(see figure 6):  
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FIGURE 6

e.g. Name:  Alternative  
Type:  Text 
Value:  ALT 

 
Name:  Reference 
Type:  Text 
Value: REF 

 
Name:  As Required 
Type:  Text 
Value:  A/R 

 
 
5.3. Additional Custom Properties 
 
A number of additional properties that link to the latest Drawing Template can also be added 
in the Custom Properties further automating our process of design to manufacture of a design 
in SolidWorks (see figure 7 below). With the development of Smart Data Templates, it is not 
necessary to add all of these properties (See section 6. Smart Data and CAD Templates).  

FIGURE 7
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6. ‘SMART’ DATA AND CAD TEMPLATES. 
 
A series of ‘Smart’ CAD and Data Templates4 have been created that will also help automate 
the design of parts and assemblies. These smart templates make the job of adding custom 
properties and making full use of them becomes even easier.  
 
6.1. ‘Smart’ Data Templates 
 
A data template is the background file that is opened when a ‘New’ file is created in 
SolidWorks.  
i.e When you go to File>New or click the  icon. The following screen will then 

 

appear:  

These are the Data Templates 
 

otice above that the new ‘Smart’ Templates, named LIGO_Part, LIGO_Assembly and 

hat makes them ‘Smart’? 

 ‘smart’ template is a template that has LIGO-personalised custom properties already 

                                                

FIGURE 8

N
LIGO_Drawing, are already downloaded here and can be edited as new files.  
 
W
 
A
embedded and, from the moment you start a SolidWorks drawing, it will prompt you for the 
information used in the LIGO BOM and LIGO CAD templates.  
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If you open one of the above ‘Smart’ Templates as a new file and go to the Custom Properties. 

 
ll of this information is linked to the BOM and Drawing Templates. And if filled in 

.2. ‘Smart’ CAD Templates 

mart CAD templates are LIGO-personalised borders for engineering drawings intrinsically 

You will notice that the following information is already programmed into the file: 

FIGURE 9

A
completely will save much time in creating the engineering drawings for the parts and 
assemblies.  
 
6
 
S
linked to the above properties. And by using these no text editing need be done to an 
engineering drawing once the part or assembly has been inserted. Programmed into the LIGO 
drawing sheets are links to the Assembly, Drawing Name, Material, Finish, Drawn by, etc 
(detailed in section 5. Setting Custom Properties) now entered in to the Customised Properties. 
This means that all drawing information is no longer edited by using ‘edit sheet format’ 
function on a sheet but by adding information to the Custom Properties of a file.  
 

Page 10 



Advanced LIGO LIGO-T030143-03-D 

7. CUSTOMISED MACRO FOR SYNCHRONISING PART AND DRAWING PROPERTIES 
 
A more recent development of the customised tools has been the addition of a macro which 
copies all properties entered into the SolidWorks Part or assembly across to its associated 
drawing file.  
 
There are two great benefits of being able to do this:  

7.1. It saves time having to type up the same data into both part (or assembly) and the 
associated drawing files custom properties.  

7.2. The properties act as Windows Metadata, which is then searchable through 
Windows Explorer (and, in future, Internet Explorer). 

 
A consequence of this is that all of these properties are transferred across when we create a pdf 
of the drawing, therefore enhancing the quality of the documentation submitted to the DCC  
 
An example scenario of how this will help us could be as follows:  
 
Sometime in the future a member of the installation team needs to know the specifications of a 
cantilever blade but they do not know what the part number of the blade is. They do know that 
however that it is a part from the Mode Cleaner Upper Mass and that Mike Plissi probably 
designed the blade. Therefore, in this example, without trawling through numerous pdf 
drawings, we could search the list for all files with ‘MVP’ or ‘MC Upper Mass’ in the 
properties.  
 
The macro, called “GOE PropSynch.swp”, is contained as an attachment to this documents 
sister paper5 and will be available on the PDMWorks vault. An example of this macro being 
used is in the appended tutorial.  

                                                 
5 D030382 
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8. SETTING OTHER PART PROPERTIES  
 
When designing suspensions it is important that we can predict accurate mass and moments of 
inertia of each of the masses so that the actual manufactured suspension can fit the necessary 
noise requirements.  
 
For SolidWorks to calculate an accurate mass we need to input the 
density into each part. The area in which this information can be 
entered can be accessed a number of ways: a) by right clicking the 
part name in the FeatureManager Design Tree and selecting 
Properties, b) by clicking the GRID icon on the ‘SKETCH’ toolbar 
(see Figure 8), or c) Tools>Options>Document Properties 

FIGURE 10

GRID 
icon 

 
This will then bring up the Document Properties window under 
which the following values of density can be entered under the 
‘Material Properties’ heading (see figure 11). 
 
 

FIGURE 11

8.1. Examples of Material Densities 
 
Alu   0.0027 grams/mm3 
Stainless Steel 0.0078 grams/mm3 
Titanium 0.0045 grams/mm3 
Fused Silica 0.002202 grams/mm3 
PEEK  0.00132 grams/mm3 
Glass (BK7) 0.0025 grams/mm3 
 
Alu  0.09754 lb/in3 
Stainless Steel 0.28179 lb/in3 
Titanium 0.16257 lb/in3 
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9. CUSTOMISED TOOLBOX. 
 
The customised toolbox6 was created following problems found with the SolidWorks Toolbox 
when passing assemblies between various engineer’s computer terminals. Following its 
creation, the customised toolbox has since been expanded to include a full range of nuts, bolts 
and washers.  
 
Once located, the toolbox should be downloaded in its entirety (preferably, or as required) to a 
local drive for usage in all Advanced LIGO assemblies. For more information on downloading 
this Toolbox, refer to document D030382 
 
 
9.1. Background to Development of the Toolbox 
 
The reason for undertaking the exercise of creating this new toolbox as opposed to continuing 
to work with the SolidWorks Toolbox is because assemblies that use the SW version always 
refer to the location of the toolbox on the workstation that is being used. This works well if 
assemblies and designs are never moved from that one machine, however with the suspension 
team being based between GEO in the UK and LIGO in the US, it has been found to be 
problematic when transferring and sharing files.  
 
When SolidWorks cannot find the existing location of it’s toolbox on, say, the C:/ drive of a 
workstation, it will automatically prompt the user to locate the whereabouts of this file. Upon 
opening the file it will then revert back to what it calls ‘the last saved configuration’ of the bolt 
(for example) and that, despite the fact you specify a #4-40 bolt, could be a #½-20 bolt! 
 
 
9.2. Using the Customised Toolbox 
 
The customised toolbox consists of a full set of Imperial and Metric nuts, bolts, washers and 
associated tools (wrenches, interlocking masses, etc) in both Stainless Steel and Silver-plated 
Stainless Steel currently used by suspensions team.  
 
The customised toolbox has been designed so that when a bolt is added to an assembly it is 
added as an actual part. By so doing, once that part has been introduced to the assembly as a 
certain size it will not change, unless the user physically changes it. To introduce a new 
Stainless steel bolt, for example, into an assembly the SolidWorks user would ‘Open’ the file 
SST_SocketHeadCapScrew.sldprt, select the appropriate configuration, then drag and drop it 
in to the assembly. Once in the assembly the user then ‘Mates’ the bolt to the interfacing parts.  
 

                                                 
6  D030383, Refer to document D030382 for information as to the location of the latest version of this. 
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The customised toolbox has the luxury that, once a bolt is inserted in to an assembly, it is very 
easy to change its configuration. For example, if a hole size increases or decreases, a change is 
simply a right click away. Figure 12 shows how a bolt can be changed:  

FIGURE 12

 
 
10. SETTING UP A WORKSTATION WITH LIGO CUSTOMISED TOOLS 
 
All Customised Tools in this document can be found on the DCC however the latest versions 
of all tools are available on the Caltech PDMWorks vault. Please refer to the top-level 
document D030382 that describes where all customised tools are located and instructs as to 
how and where these should be downloaded.  
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11. THE PDMWORKS VAULT 
 
It is the intention of the suspensions team that, from the publication of this document onwards, 
all part, assembly and engineering drawing documents in SolidWorks, pdf and universal CAD 
format (SAT) are all stored on the CalTech PDMWorks vault. This replaces Sirius as the 
storage location for future controls and noise prototypes, and finalised suspension designs. It 
has become apparent through testing at CalTech, MIT and Glasgow that this Data 
Management tool provides the solution to the problem of designing suspension assemblies and 
their associated surrounding architecture, safely and securely across a number of locations and 
countries.  
 
The following sections highlight some points on PDMWorks usage and general convention for 
naming design files specific to the Advanced LIGO project. For full instruction as to how to 
use PDMWorks please refer to the help files. 
 
11.1. Rules for Creation and Naming of Files for the Vault 
 

10.1.1. Part files should be named like this:  
D040xyz_`Suspension’_`Sub-System’_`Description’.sldprt; 
e.g.  D040036_ETM_TEST_MASS.SLDPRT. 

10.1.2. Assembly files should be named like this: 
D040abc_`Suspension’_Assembly_`Sub-System’.sldasm; 
e.g.  D040038_ETM_Assembly_Test_Mass.SLDASM. 

10.1.3. Drawings should be named as per their associated part or assembly (sldprt):  
e.g.  D040038_ETM_Assembly_Test_Mass.SLDDRW; 
or D040036_ETM_TEST_MASS.SLDDRW. 

10.1.4. Drawings should, once completed, be converted into .pdf format with and 
embedded .SAT file. This can either be done using BlueBeam7 or using Adobe 
Acrobat (full version), which allows SATs to be embedded in pdf files.  

10.1.5. For assemblies it is also encouraged that an isometric rendering in jpeg format 
is also checked into the vault. These will be very useful when preparing 
presentation material or writing report and papers.  

 
11.2. Management of the Vault 
 
The management of the vault at the Administrator level will be undertaken by Mike Pedraza of 
Caltech. The vault will be backed up every day so that should something go wrong we can 
check back to the previous days file structure.  
 
Other than this PDMWorks vault manages itself as it automatically identifies old or new files 
being uploaded, or indeed the same unchanged files being uploaded and issues revision 
numbers when necessary. Files can be ‘owned’ by any member of the vault – where this is the 
case, specific files can be downloaded but only as read only. If however the file is resaved 
locally by that new owner and uploaded, it will be checked in with a new revision number.  

                                                 
7 Bluebeam PDF - www.bluebeam.com have created an icon based pdf creation tool which simplified the process 
of creating pdfs and embedded SAT files. Now also available from SolidWorks (www.SolidWorks.com)  
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11.3. Checking files in to the Vault 
 

11.3.1. Files should be checked in with the appropriate naming convention (see 10.1.) 
11.3.2. The correct ‘Project’ should be selected for the file being checked in. The 

‘Project’ is the directory or folder under which the file will be listed.  
11.3.3. Non-CAD files such as pdf’s, jpeg’s, word documents, and excel spreadsheets 

can be referenced to other files on the vault should their information be linked 
somehow. 

 
11.4. Other features of the Vault 

 
11.4.1. SolidWorks files and their revisions. In the custom properties of the Smart Data 

templates there is a reference to a file’s ‘Revision’. All Smart CAD templates 
are set up to automatically use the PDMWorks revision information, however 
should you wish to over-ride this function – your specified revision number can 
be manual entered into the custom properties of the file.  

11.4.2. Revisions occur every time an item is are checked out, edited and checked back 
in to the PDMWorks vault.  

11.4.3. To re-iterate, all of the customised tools described in this document will be 
available in the Caltech PDMWorks vault. Please refer to the document 
D030382 for advisory notes on locating and downloading the files.  
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12. CONCLUSIONS 
 
This document overviews how to enter the particular information that is required to use the 
LIGO BOM to its full potential and how to enter all the information that the Suspension team 
has found useful to incorporate so far. It is possible to further tailor the BOM or Custom 
Properties to suit many more needs, but a balance must be made on how time consuming this 
over and above the future benefits of doing this. 
 
The improvements in the document are comprehensive but hopefully, once set-up, are 
straightforward and well integrated. It is important to note that they have currently been set-up 
to match the requirements of the suspensions team. Other design teams within the LIGO 
collaboration may find that these improvements need to be expanded or further customised to 
match their exact needs. The authors would be interested to hear of any new suggestions or 
further customisation of the above tools.  
 
Authors: 
Michael Perreur-Lloyd:  
Institute for Gravitational Research, University of Glasgow, mplloyd@physics.gla.ac.uk 
Calum Torrie: 
LIGO Project, California Institute for Technology, ctorrie@ligo.caltech.edu  
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Tutorial Example 

 
This tutorial demonstrates the functions used in creating a typical test mass assembly with the 
required information to produce an automatic Bill of Materials. This tutorial is designed to 
integrate with D030384_08_LIGOBOM.xls and the LIGO Customised Tools described earlier in 
this document. Please ensure that all necessary updates have been completed as this tutorial is 
designed to make full use of the new functionality. 
 
NOTE: Some of these tutorials screenshots were taken prior to the most recent document revision 
please refer to the main document (which has been fully updated) should you notice anything 
unusual. (e.g. the custom properties shown in the tutorial - pages 6 to 8 - have small letters) 
To begin, open a new LIGO_Part:  
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DRAWING TEST 
MASS ASSEMBLY 
PARTS 
 
1. Open new part 
file. Draw up test 
mass front view 
with dimensions as 
shown (left) 
 
2. Extrude-Boss, 
mid plane to a 
depth of 60mm 

 

3. On Flat, Draw 
#4-40 holes for 
break off ears 
(0.125in/3.18mm). 
Holes should be 
1mm above centre 
line for mass. 
 
4. Extrude-Cut, to 
a depth of 8mm. 
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7. Open New Part 
File. Draw profile 
shown (left). 
 
8. Extrude-Boss, 
mid plane to a 
depth of 30mm.  

5. Mirror holes to 
break off ears 
about RIGHT 
plane. 
 
6. Drawing 
complete, save as 
Test Mass.sldprt 
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9. Select RIGHT 
plane and draw the 
profiles shown 
(top left).  
 
10. Extrude-Cut, to 
a depth of 8mm to 
get profile shown 
in the following 
screen capture 
(inset bottom left). 
 
11. Select TOP 
plane. Draw V-
shaped wire 
groove making the 
vertical v-line co-
incident/co-linear 
with the ‘silhouette 
edge’. Mirror 
about Centreline. 
 
12. Extrude-Cut-
Revolve around 
vertical axis shown 
(bottom left) 
IX PAGE 3 
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13. Select RIGHT 
Plane. Draw 
circular profiles 
shown, 4mm from 
either edge of the 
part (left). 
 
14. Extrude-Cut, 
through part.  

15. Part Complete. 
Save as Test Mass 
Ear.sldprt 
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16. Open New Part 
file. Sketch 
Circular profile 
(30mm DIA.). 
 
17. Extrude-Boss, 
to a depth of 
60mm.  
 
18. Part Complete. 
Save as Test Mass 
Extra Mass.sldprt 
IX PAGE 5 
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EDITING CUSTOM 
& MATERIAL 
PROPERTIES 
 
19. Re-open Test 
Mass.sldprt. Go to 
File>Properties. 
 
20. Select the 
Custom tab - you 
will now notice a 
full list of custom 
information 
prompts (top left).
 
21. Enter the 
information shown 
(bottom left). 
Make sure that the 
‘Modify’ button is 
pressed after each 
entry.  
 
This information 
will be picked up 
by the BOM and 
Smart Drawing 
Template when 
opened (later in 
the tutorial).  
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22. Right-click 
Part Name in 
FeatureManager 
Design Tree. 
Select ‘Document 
Properties’. 
 
23. In ‘Document 
Properties’, select 
‘Material 
Properties’.  
 
24. Type: 
Density=
gram/mm^3 

 0.0078 

 
25. OK and save 
Part. 
26. Open Test 
Mass Ear.sldprt. 
Repeat steps 19-25 
using information 
shown (bottom 
left)
IX PAGE 7 
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27. Open Test 
Mass Extra 
Mass.sldprt. 
Repeat steps 19-25 
using information 
shown (top left & 
bottom left).  
 
NOTE: an extra 
instruction 
‘asrequired: A/R’ 
has been added.   
 
NOTE: the extra 
masses are 
Aluminium and 
should have a 
Density of 
0.0027g/mm^3.
IX PAGE 8 
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Creating the Test 
Mass Assembly 
 
28. Open all parts 
and a new 
LIGO_Assembly 
file.  
 
29. Arrange Parts 
in the Assembly 
file as shown 
(bottom left).  
Close the part files
IX PAGE 9 
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Adding 
Customised 
Toolbox Bolts 
 
31. Go to 
Customised 
Toolbox directory, 
Open File: Ag-
SST_Socketheadca
pscrew.sldprt 
 
32. Select 
Configuration 
‘SHCS #4-40 X 
0.4375’ from the 
SW Configuration-
Manager 

Hiding ‘As 
Required’ Parts 
 
To ensure that we 
show the ‘Test 
Mass Extra 
Masses’ as an ‘As 
Required’ part in 
the Bill of 
Materials we need 
to hide them in the 
assembly:  
 
30. Select all Extra 
Mass parts, right 
click and Hide as 
shown (left). 
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Editing 
Customised 
Toolbox 
Component 
Properties 
 
If we decide that 
the bolt we have 
inserted is the 
wrong size this can 
easily be altered: 
 
36. Right-click 
surface of bolt 
head or it’s name 
in the feature 
manager design 
tree, select 
‘Component 
Properties…’ 
 
37. Change all bolt 
configurations to 
#4-40 X 0.375 (see 
bottom left and top 
screenshot on the 
next page) 

33. Drag and drop 
four bolts into 
assembly 
 
34. Mate bolts into 
holes for break off 
ears.  
 
35. Close bolt file 
– Do not save. 
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38. Fill in Custom 
Properties as per 
the screenshot 
(left).  
 
39. Save Assembly 
File as: 
Assembly_Test_M
ass.sldasm 
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CREATING A 
FULLY 
AUTOMATED 
ENGINEERING 
DRAWING 
 
40. Open a new 
LIGO_Drawing 
file 
 
41. Insert a 
‘Custom Sheet 
format’ and select 
the LIGO 
‘bsize.slddrt’ 
template. 
ADDING A BILL OF 
MATERIALS 
42. Attach the 
assembly by 
dragging it from 
the assembly 
window into the 
drawing window. 
(This is best done 
by holding CTRL 
and dragging the 
assembly name 
from the top of the 
Featuremanager 
design tree)  
 
43. Select any 
view of the 
assembly in the 
drawing and go to: 
Insert>Bill of 
Materials as shown 
(top left). Open 
‘D030384_07_LIG
OBOM.xls’.
X PAGE 13 
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44. Check and/or 
uncheck Bill of 
Materials 
‘Configuration’ 
Properties as 
shown (bottom 
left). 
 
45. Click 
‘Contents’ tab (the 
bill of materials 
will now open 
excel and begin 
calculation), 
Uncheck ‘Display 
labels at top’. OK. 
 
The Bill of 
Materials will now 
be on your 
drawing sheet, 
however it will not 
be showing all 
information.  
 
46. Move to 
position (above 
‘Parts List’) then 
double click to re-
calculate Excel 
functions.    
 
47. An Excel type 
window will open 
as shown (top left). 
All information 
should now be 
shown. To get out 
left-click the 
drawing sheet.  
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CUSTOM PROPERTIES IN A 
DRAWING 
 
To indicate that a drawing has been 
checked. This should be done in the 
drawing’s custom properties. 
 
48. Go to File>Properties>Custom 
Properties. Enter the checker’s name and 
date.  
 
Should you require to add further notes 
to the drawing, e.g. manufacture notes, 
this can still be done by right clicking the
drawing and pressing ‘edit sheet format’.
 
COPYING ACROSS CUSTOM 
PROPERTIES FROM A PART (OR 
ASSEMBLY) TO A DRAWING 
 
49. Go to: Tools>Macro>Run… Select 
the GOE PropSynch.swp macro and 
‘Open’.  
Now, when you save your drawing a 
window should pop us asking whether 
you wish to ‘Synchronise document 
properties?’ Select ‘YES’. 
APPENDIX PAGE 15 
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SUBMITTING THE 
FILES TO THE 
PDMWORKS VAULT 
 
There are a few ways in 
which you can check-in 
documents to the vault.  
Here is one of them: 
 
With all SolidWorks files 
closed 
 
54. Login to the 
PDMWorks vault as 
prompted at SolidWorks 
Startup or otherwise.  
 
55. Go to 
File>PDMWorks Open…
The PDMWorks screen 
(left) will appear.   
50. Open the custom properties 
again 
(File>Properties>Custom 
Properties). You will notice
that all properties from the 

 

part/assembly are now 
contained within the drawing 

s shown left) 

now 

ssembly_Test_Mass.slddrw’ 

d at the end of 
the appendix.  

(a
 
52. The Drawing is 
complete. Save as: 
‘A
 
53. The drawing should look 
like that attache
APPENDIX PAGE 16 
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s  

58. The following 
window will open. Check
that all of the appro
documents are being 
copied across and check 
that the ‘Project’ is 
correct.  

 
priate 

h 

 
59. Select ‘Check-in’ 
once you are happy wit
all setting
 
It is advisable that once a 
sub-assembly is 
completed, it is checked 
in to the vault and deleted 
locally.  
PDMWorks advises of 
latest revisions should the 
user try to download a 
document that they 
already have locally. 

56. Open the local folders 
to the file you wish to add 
to the  vault.  
 
57. Drag and Drop the file 
to the appropriate folder 
on the vault (e.g. 
‘Example Project fro 
T030143’, shown left)
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60. Select ‘Yes’ to the 
messages that appear on 
checking the documents 
in.  
 
61. You will now notice 
that all files have been 
transferred across in a 
hierarchical order below 
the Project folder (see 
screenshot left). 
 
You will also notice that  
 The files that have been 
checked in show a grey 
symbol rather than a blue 
symbol next to the file 
name (top left corner) 
CHECKING IN A PDF 
DOCUMENT AND 
REFERENCING TO 
AN ASSOCIATED 
SOLIDWORKS FILE  
 
This also shows another 
method for checking in a 
document! 
 
62. Create and save a PDF 
of the SolidWorks 
drawing file. 
 
63. Right click the 
appropriate file and select 
‘Check in this 
Document…’ (see left) 
PPENDIX PAGE 18 
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64. Select the correct 
‘Project’ as shown top-
left.  
 
65. Next, click the box 
References: ‘Add’  
 
The following screen will 
appear (see screenshot 
bottom left) 
 
66. Locate the top-level 
file that is associated with 
your pdf and select OK.  
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67. The documents are now fully checked in. The process of
checking in a PDF can be repeated for jpegs, Word documents
Excel spreadsheets, etc. 
 

END. 
 
See over for the completed engineering drawing of
Assembly_Test_Mass. 
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