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DESIGNING IN SOLIDWORKS 
 

Customised Tools for Design and Documentation of   
LIGO Parts, Assemblies and Drawings 

 
 

1.  INTRODUCTION 
 
This document outlines how to attach information to SolidWorks parts, assemblies and 
drawings to aid the production of consistent engineering drawings, bill of materials, drawing 
trees and materials lists. 
 
The Bill of Materials [BOM] and Drawing Tree are essential documents required by LIGO 
that follow all designed parts from manufacture through to assembly. The LIGO Mechanical 
Drawing Guidelines document1 indicates that it is also useful, when sending a drawing pack 
for manufacture, if the major assemblies have an overall BOM (a, so called, materials list). In 
past LIGO projects it was necessary to create all of these as separate documents in programs 
such as Word or Excel, however by implementing the SolidWorks ‘Bill of Materials’ function 
it is possible to produce the documents automatically.  
 
To help the automation of these, a LIGO Bill of Materials2 has been designed that is tailored to 
ensure that the information detailed in the Mechanical drawing guidelines is correctly 
tabulated. Alongside this, ‘Smart’ CAD templates, ‘Smart’ Data templates, and the 
Customised Toolbox have been developed to automate the creation of parts, assemblies and 
engineering drawings.  
 
By establishing an array of customised tools it becomes easier to standardise the information 
shown in every part, assembly, and engineering drawing, thus improving the quality of the 
documentation. And by automating the production of the supplementary documents through 
entering information during the design stage, we will make time to focus on other areas of the 
project. 
 
Following the description and explanation of the LIGO Customised Tools, a step-by-step 
tutorial provides an example of the procedures used to produce a part, an assembly and a 
mechanical drawing with a the BOM, Materials List or Indented Drawing tree. 
 

                                                 
1 E030350-00-D Mechanical Drawing Guidelines, http://www.ligo.caltech.edu/docs/E/E030350-00.pdf, D Coyne  
2 D030384-07_LIGOBOM.xls, http://www.ligo.caltech.edu/docs/D/D030384-07_LIGOBOM.xls, M Perreur-
Lloyd and C Torrie 
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2.  PART PROPERTIES FOR THE BOM 
 

ITEM NO REQ. SPARE TOT. PART NUMBER DESCRIPTION MATERIAL 

              

              

 
2.1. Item Number Column 
 
2.1.1. Default Properties 
 
SolidWorks has a number of default settings to each of the columns in the BOM. In the case of 
the Item number it will automatically choose an item number depending on the order that parts 
are entered into an assembly. These are the same numbers shown when balloon numbers are 
added to a drawing. In some situations, however, we need to call up parts without showing 
them in an assembly drawing therefore the we have designed the LIGO BOM with several 
new functions that will over-write the default information with a more customised form.  
 
2.1.2. Hidden Parts and Assemblies 
 
In an assembly it is often necessary to have additional parts or sub-systems that are not 
eventually used in the final system, for example (in terms of a suspension prototype): a wire 
jig; an extra mass; an angled blade clamp. In the bill of materials for an assembly it is 
necessary to differentiate between these components depending upon their usage in the 
assembly. In this situation these should be referred to as one of the following: 
 

ALT:  ‘Alternative’, e.g. an angled blade clamp. This component would only be used 
in a suspension assembly should a blade be deflecting above or beyond the 
optimum height.  

REF: ‘Reference’, e.g. a wire jig. This sub-assembly was used in the in the 
construction of the suspension assembly, however is not part of the assembled 
suspension and hence need not be displayed on the assembly drawing 
document.  

A/R: ‘AsRequired’, e.g. an extra mass. This part is only required should the optic of 
a suspension assembly, once fully suspended, be hanging too high. In this 
situation an ‘extra mass’ or a number of ‘extra masses’ are added, as required.  

 
All of the above component types are entered into the custom properties of a drawing. 
SolidWorks custom properties are explained in section 4, ‘Setting Custom Properties in 
SolidWorks’ and further relayed in the appended tutorial (see Appendix 1).  
 
2.2. Required Column 
 
SolidWorks automatically calculates the quantity of each part from the number of parts 
entered an assembly. However, when we need to specify that more than one assembly is to be 
built we need to be able to multiply the automatic defaults by however many assemblies we 
are having manufactured. 
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Again this can be done in the Custom Properties:   
 

REQ:  ‘Required’, the total number of parts required to build an assembly or a 
number of assemblies (not including spares). 

 
2.3. Spare Column 
 
Again SolidWorks has a default setting, that is: the number of Spares is equal to the number of 
parts (i.e. 10 parts made, 10 spares made). As it is likely that this will not be the requirement 
for all parts it is possible to override this setting using the function:  

 
SPARE:  If ‘spare’ is entered in the custom properties along with the desired value, 

this will override the default.  
 
2.4. Total Column 
 
The ‘total’ column is far more self-explanatory and is purely a sum of the ‘required’ and 
‘spare’, detailed above. No custom properties are set for Total.  
 
2.5. Material Column 
 
Material is a column that has no default value as it has been created specifically for use in the 
LIGO BOM. It is important to enter a material custom property for all parts as the BOM will 
be the sole place that this information will be contained (individual engineering drawing of 
parts do not show material). The number of character spaces in the Material column is limited 
so below are some examples of typical material acronyms.  
 
 300 SSTL:  300 Series Stainless Steel 
 6061-T6-Al:  6061-T6 Aluminium (US specification) 
 6082-T6-Al:  6082-T6 Aluminium (UK specification) 
 PEEK [NAT]:  PEEK natural or virgin grade 
 
2.6. Part Number Column 
 
The LIGO BOM is set up such that the seven-digit part number associated with the LIGO 
Document Control Centre (DCC), e.g. D020123, will automatically be picked up from the 
Custom Properties: 

e.g.  D020123:  Enter ‘number’ into the custom properties, followed by the part 
or assembly’s DCC number. 

 
2.7. Description Column 
 
Again the LIGO BOM has been set-up to automatically pick up Part description from the 
Custom Properties: 

e.g.  Angled Blade Clamp:  Enter ‘description’ into the custom properties followed 
by the part name for this to link in to the BOM automatically.  
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3. CREATING A BILL OF MATERIALS, DRAWING TREE OR MATERIALS LIST 
 
To create a Bill of Materials, Drawing Tree or Materials List by using the LIGOBOM, it is 
simply a matter of selecting the appropriate settings in the SolidWorks Bill of Materials 
function. All of these functions are available when a drawing (.slddrw) of an assembly is open. 
For example: 

FIGURE 1

By selecting any of the assembly views on the drawing sheet and then, from the Main Heading 
Toolbar, Insert>Bill of Materials (You will notice that this is only highlighted when your 
assembly view is highlighted) you will open up the. Bill of Materials function 
 
This will then prompt you to open 
up a BOM.xls file from a list of 
files in Solidworks. At this point it 
is required that the file:  

FIGURE 2

D030384-07_LIGOBOM.xls  
is located.  
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Once the D030384-07_LIGOBOM.xls is located, the following window shall open up on your 
screen:  

FIGURE 3

 
And it is by using this interface that the selections can be made to tabulate a BOM, Drawing 
Tree or Materials List.  
 
3.1. General Notes  
 

• It is advisable for all tables that the first two boxes are left unchecked, i.e. Do not ‘Use 
Summary Information title as part number’ and Do not ‘Use the document’s note font 
when creating the table’. The LIGO BOM is set-up such that the font size in the excel 
table will create a table with a width equal to the note box on the bottom right corner of 
a drawing sheet.  

• The ‘use table anchor point box’ and the ‘Add new items by extending top border of 
table’ should also left unchecked 

 
3.2. Creating a Bill of Materials  
 
To create a bill of materials, the box that should be checked on the ‘Configuration’ area of the 
‘Bill of Materials Properties’ is:  

  
And on the ‘Contents’ area of the ‘Bill of Materials Properties’ uncheck ‘Display labels at top’ 
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3

 Materials, Drawing Tree or Materials List can be either kept in 

FIGURE 4

.3. Creating a Indented Drawing Tree 

o create an Indented Drawing Tree, the important boxes that should be checked are:  

 
.4. Creating a Materials List 

reating a materials list is now very similar to creating a LIGO bill of material (Section 3.1) 

o create an Indented Drawing Tree, the following box should be checked:  

.5. Finishing off 

nce the correct boxes are checked and OK pressed, a BOM table will appear on the Drawing 

he Table can then 

ll information in the Bill of

 
T

3
 
C
with exception ‘display labels at top’ should be checked. Where a Bill of Materials is used on 
every assembly and sub-assembly, a Materials List is used only on Major assemblies and 
generally created prior to a drawing package being sent out to tender.  
 
T

 And, to reiterate, ‘Display labels at top’ under the ‘Contents’ Tab should also be checked.  
 
3
 
O
sheet. It is likely, however, that none or very little information is shown at first. The reason for 
this is that the added functions - the equations from Excel - have not yet been solved. You can 
update these functions by double clicking the table (which triggers Excel to open and 
calculations to be done) and then by clicking back on the drawing sheet again, this will close.  
 
T
be moved into 
position, above the 
Drawing sheets 
PART LIST title box, 
by simply dragging 
the table to this 
location (as shown in 
Figure 4)  
 
 
A
the SolidWorks drawing sheets or copied to an Excel Spreadsheet for inclusion in another 
document. It is important to note that, to keep the information up-to-date, it is advisable that 
the tables remain in SolidWorks until a point where all drawings are finalised i.e. just prior to 
Manufacture. 
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4. SETTING CUSTOM PROPERTIES IN SOLIDWORKS 
 
SolidWorks custom properties are very useful as they encourage us to embed important 
information into the part, assembly and drawing files and more importantly this information 
can be then be linked to other SolidWorks tools such as the Bill of Materials function and the 
Drawing Sheet.  
 
The Custom and Summary Properties window can be opened by going File>Properties.  

FIGURE 5

 
4.1. Summary Properties 
 
The first window in File>Properties will show the Summary Properties. This area is like any 
Microsoft file where you can store useful information about the file and when it was created, 
etc. Although it is not a necessity to store information here it will is a good exercise to 
practice. By clicking the top ‘Custom’ Tab we can now begin editing the custom properties.  
 
4.2. Custom Properties 
 
This is the key area in which you can enter the important information that links to the Bill of 
Materials and Drawing sheet. As shown in Figure 5 (Right) above the information described 
earlier about Required, Spare, Material, etc can be entered here.  
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In the case of Alternative, Reference and As Required parts these should be entered as follows 
(see figure 6):  
 

FIGURE 6

e.g. Name: Alternative  
Type: Text 
Value: ALT 

 
Name: Reference 
Type: Text 
Value: REF 

 
Name: As Required 
Type: Text 
Value: A/R 

 
 
4.3. Additional Custom Properties 
 
A number of additional properties that link to the latest Drawing Template can also be added 
in the Custom Properties further automating our process of design to manufacture of a design 
in SolidWorks (see figure 7 below). With the development of Smart Data Templates, it is not 
necessary to add all of these properties (See section 5. Smart CAD and Data Templates).  

FIGURE 7
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5. SMART CAD AND DATA TEMPLATES. 
 
A series of ‘smart’ CAD and Data templates have been created that will also help automate the 
design of parts and assemblies. These smart templates make the job of adding custom 
properties and making full use of them becomes even easier.  
 
5.1. Smart Data Templates 
 
A data template is the background file that is opened when a ‘New’ file is created in 
SolidWorks.  
i.e When you go to File>New or click the  icon. The following screen will then 

 

appear:  

These are the Data Templates 
 

otice above that the new ‘Smart’ Templates, named LIGO_Part, LIGO_Assembly and 

hat makes them ‘Smart’? 

 ‘smart’ template is a template that has LIGO-personalised custom properties already 

FIGURE 8

N
LIGO_Drawing, are already downloaded here and can be edited as new files.  
 
W
 
A
embedded and, from the moment you start a SolidWorks drawing, it will prompt you for the 
information used in the LIGO BOM and LIGO CAD templates.  
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If you open one of the above ‘Smart’ Templates as a new file and go to the Custom Properties. 

ll of this information is linked to the BOM and Drawing Templates. And if filled in 

.2. Smart CAD Templates 

mart CAD templates are LIGO-personalised borders for engineering drawings intrinsically 

You will notice that the following information is already programmed into the file: 
 

FIGURE 9

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
A
completely will save much time in creating the engineering drawings for the parts and 
assemblies.  
 
5
 
S
linked to the above properties. And by using these no text editing need be done to an 
engineering drawing once the part or assembly has been inserted. Programmed into the LIGO 
drawing sheets (D030382) are links to the Assembly, Drawing Name, Material, Finish, Drawn 
by, etc (detailed in section 4. Setting Custom Properties) now entered in to the Customised 
Properties. This means that all drawing information is no longer edited by using ‘edit sheet 
format’ function on a sheet but by adding information to the Custom Properties of a file.  
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6. SETTING OTHER PART PROPERTIES  
 
When designing suspensions it is important that we can predict accurate mass and moments of 
each of the masses so that the actual manufactured suspension can fit the necessary noise 
requirements. For solidworks to calculate an accurate mass we need to input the density into 
each part. The area in which this information can be entered can be 
a number of ways: a) by right clicking the part name in the 
FeatureManager Design Tree and selecting Properties, b) by 
clicking the GRID icon on the ‘SKETCH’ toolbar (see Figure 8), or 
c) Tools>Options>Document Properties 

FIGURE 10

GRID 
icon  

This will then bring up the Document Properties window under 
which the following values of density can be entered under the 
‘Material Properties’ heading (see figure 11). 
 
 

FIGURE 11

Alu   0.0027 grams/mm3 
Stainless Steel 0.0078 grams/mm3 
Titanium 0.0045 grams/mm3 
PEEK  0.00132 grams/mm3 
 
Alu  0.09754 lb/in3 
Stainless Steel 0.28179 lb/in3 
Titanium 0.16257 lb/in3 
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7. CUSTOMISED TOOLBOX. 
 
The customised toolbox (http://www.ligo.caltech.edu/docs/D/D030383-03) was created 
following problems found with the SolidWorks Toolbox when passing assemblies between the 
engineers in the US and the UK. Following it’s creation, the customised toolbox has since 
been expanded to include a full range of nuts, bolts and washers incorporated in LIGO 
Suspension design further automating the design process. 
 
The Customised toolbox consists of a full set of Imperial and Metric nuts, bolts, washers and 
associated tools (wrenches, interlocking masses, etc) in both Stainless Steel and Silver plated 
Stainless Steel currently used by suspensions team. The reason for undertaking the exercise of 
creating this new toolbox as opposed to continuing to work with the SolidWorks version is 
because assemblies that use the SW toolbox always refer to the location of the toolbox on the 
workstation that is being used. This works well if assemblies and designs are never moved 
from that one machine, however with the suspension team being based between GEO in the 
UK and LIGO in the US, it has already to be found to have problems when transferring and 
sharing files.  
 
When SolidWorks cannot find the existing location of it’s toolbox on, say, the C:/ drive of a 
workstation, it will automatically prompt the user to locate the whereabouts of this file. Upon 
opening the file it will then revert back to what it calls ‘the last saved configuration’ of the bolt 
(for example) and that, despite the fact you specify a #4-40 bolt, could be a #½-20 bolt! 
 
To ensure these problems do not occur again, the customised toolbox has been designed so 
that when a bolt is added to an assembly it is added as an actual part. By so doing, once that 
part has been introduced to the assembly as a certain size it will not change, unless the user 
physically changes it. The Customised toolbox also has the luxury that the bolts are very easy 
to change once inserted in to an assembly such that, if a hole size increased or decreased a 
change is simply a right click away. Figure 12 shows how a bolt can be changed:  
 

 
The Customised toolbox can be found on the DCC.   

FIGURE 12
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8. SETTING UP A WORKSTATION WITH LIGO CUSTOMISED TOOLS 
 
All aforementioned tools and customised SolidWorks functions have been allocated LIGO 
DCC numbers and can be found in this Database. All of the tools should be download to the 
appropriate location at the same time and should ideally be used at all times during the design 
of parts for the Advanced LIGO project. All of these tools have been saved to the DCC as .zip 
to make downloading of the files very straightforward. 
 
PDF Documents have been created alongside the tools zip files giving instruction of where the 
tools should be downloaded to and details of what tools are included in the zip files. The DCC 
numbers are as follows:  
 

D030382-03_Customised Smart CAD and DATA Templates for SolidWorks.zip 
D030382-03_Customised Smart CAD and DATA Templates for SolidWorks.pdf 
D030383-03_Customised Toolbox for SolidWorks.zip 
D030383-03_Customised Toolbox for SolidWorks.pdf 
D030384-07_LIGOBOM.xls  

 
In the case of the Bill of Materials, D030384-07_LIGOBOM.xls, it is advisable for ease of use 
that this should be downloaded to:  

//Program Files/Solidworks/lang/english/  
 
as this is where all of the other SolidWorks Bill of Materials templates are stored.  
 
Note: Older revisions of the Customised tools are also located on the DCC and may be found 
during a DCC search. Where this is the case, locate and download the latest revisions of these. 
The latest revisions at time of press are those seen above.  
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9. CONCLUSIONS 
 
This document overviews how to enter the particular information that is required to use the 
LIGO BOM to its full potential and how to enter all the information that the Suspension team 
has found useful to incorporate so far. It is possible to further tailor the BOM or Custom 
Properties to suit many more needs however a balance must be made on how time consuming 
this is above the future benefits of doing this. 
 
The improvements in the document are comprehensive but hopefully, once setup, are straight 
forward and well integrated. It is important to note that they have been set up to match the 
requirements of the suspensions team. Other design teams within the LIGO collaboration may 
find that these improvements need to be expanded or further customised to match their exact 
needs. The authors would be interested to hear of any new suggestions or further 
customisation of the above tools.  
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APPENDIX 1 
 

Tutorial Example 
 
 

This tutorial demonstrates the functions used in creating a typical test mass assembly with the 
required information to produce an automatic Bill of Materials. This tutorial is designed to 
integrate with D030384_07_LIGOBOM.xls and the LIGO Customised Tools described earlier in 
this document. Please ensure that all necessary updates have been completed as this tutorial is 
designed to make full use of the new functionality.  
To begin, open a new LIGO_Part:  
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DRAWING TEST 
MASS ASSEMBLY 
PARTS 
 
1. Open new part 
file. Draw up test 
mass front view 
with dimensions as 
shown (left) 
 
2. Extrude-Boss, 
mid plane to a 
depth of 60mm 

 

3. On Flat, Draw 
#4-40 holes for 
break off ears 
(0.125in/3.18mm). 
Holes should be 
1mm above centre 
line for mass. 
 
4. Extrude-Cut, to 
a depth of 8mm. 
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7. Open New Part 
File. Draw profile 
shown (left). 
 
8. Extrude-Boss, 
mid plane to a 
depth of 30mm.  

5. Mirror holes to 
break off ears 
about RIGHT 
plane. 
 
6. Drawing 
complete, save as 
Test Mass.sldprt 
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9. Select RIGHT 
plane and draw the 
profiles shown 
(top left).  
 
10. Extrude-Cut, to 
a depth of 8mm to 
get profile shown 
in the following 
screen capture 
(inset bottom left). 
 
11. Select TOP 
plane. Draw V-
shaped wire 
groove making the 
vertical v-line co-
incident/co-linear 
with the ‘silhouette
edge’. Mirror 
about Centreline. 
 
12. Extrude-Cut-
Revolve around 
vertical axis shown
(bottom left) 
IX PAGE 3 
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15. Part Complete. 
Save as Test Mass 
Ear.sldprt 

13. Select RIGHT 
Plane. Draw 
circular profiles 
shown, 4mm from 
either edge of the 
part (left). 
 
14. Extrude-Cut, 
through part.  
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16. Open New Part 
file. Sketch 
Circular profile 
(30mm DIA.). 
 
17. Extrude-Boss, 
to a depth of 
60mm.  
 
18. Part Complete. 
Save as Test Mass 
Extra Mass.sldprt 
IX PAGE 5 
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EDITING CUSTOM 
& MATERIAL 
PROPERTIES 
 
19. Re-open Test 
Mass.sldprt. Go to 
File>Properties. 
 
20. Select the 
Custom tab - you 
will now notice a 
full list of custom 
information 
prompts (top left).
 
21. Enter the 
information shown 
(bottom left). 
Make sure that the 
‘Modify’ button is 
pressed after each 
entry.  
 
This information 
will be picked up 
by the BOM and 
Smart Drawing 
Template when 
opened later in the 
tutorial.  
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22. Right-click 
Part Name in 
FeatureManager 
Design Tree. 
Select ‘Document 
Properties’. 
 
23. In ‘Document 
Properties’, select 
‘Material 
Properties’.  
 
24. Type: 
Density=
gram/mm^3 

 0.0078 

 
25. OK and save 
Part. 
26. Open Test 
Mass Ear.sldprt. 
Repeat steps 19-25 
using information 
shown (bottom 
left)
IX PAGE 7 
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27. Open Test 
Mass Extra 
Mass.sldprt. 
Repeat steps 19-25 
using information 
shown (top left & 
bottom left).  
 
NOTE: an extra 
instruction 
‘asrequired: A/R’ 
has been added.   
 
NOTE: the extra 
masses are 
Aluminium and 
should have a 
Density of 
0.0027g/mm^3.
IX PAGE 8 
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Creating the Test 
Mass Assembly 
 
28. Open all parts 
and a new 
LIGO_Assembly 
file.  
 
29. Arrange Parts 
in the Assembly 
file as shown 
(bottom left).  
Close the part files
IX PAGE 9 
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Adding 
Customised 
Toolbox Bolts 
 
31. Go to 
Customised 
Toolbox directory, 
Open File: Ag-
SST_Socketheadca
pscrew.sldprt 
 
32. Select 
Configuration 
‘SHCS #4-40 X 
0.4375’ from the 
SW Configuration-
Manager 

Hiding ‘As 
Required’ Parts 
 
To ensure that we 
show the ‘Test 
Mass Extra 
Masses’ as an ‘As 
Required’ part in 
the Bill of 
Materials we need 
to hide them in the 
assembly:  
 
30. Select all Extra 
Mass parts, right 
click and Hide as 
shown (left). 
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Editing 
Customised 
Toolbox 
Component 
Properties 
 
If we decide that 
the bolt we have 
inserted is the 
wrong size this can 
easily be altered: 
 
36. Right-click 
surface of bolt 
head or it’s name 
in the feature 
manager design 
tree, select 
‘Component 
Properties…’ 
 
37. Change all bolt 
configurations to 
#4-40 X 0.375 (see 
bottom left and top 
screenshot on the 
next page) 

33. Drag and drop 
four bolts into 
assembly 
 
34. Mate bolts into 
holes for break off 
ears.  
 
35. Close bolt file 
– Do not save. 
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38. Fill in Custom 
Properties as per 
the screenshot 
(left).  
 
39. Save Assembly 
File as: 
Assembly_Test_M
ass.sldasm 
 



  APPENDIX 1 

APPENDI

CREATING A 
FULLY 
AUTOMATED 
ENGINEERING 
DRAWING 
 
40. Open a new 
LIGO_Drawing 
file 
 
41. Insert a 
‘Custom Sheet 
format’ and select 
the LIGO 
‘bsize.slddrt’ 
template. 
ADDING A BILL OF 
MATERIALS 
42. Attach the 
assembly by 
dragging it from 
the assembly 
window into the 
drawing window. 
(This is best done 
by holding CTRL 
and dragging the 
assembly name 
from the top of the 
Featuremanager 
design tree)  
 
43. Select any 
view of the 
assembly in the 
drawing and go to: 
Insert>Bill of 
Materials as shown
(top left). Open 
‘D030384_07_LIG
OBOM.xls’.
X PAGE 13 
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44. Check and/or 
uncheck Bill of 
Materials 
‘Configuration’ 
Properties as 
shown (bottom 
left). 
 
45. Click 
‘Contents’ tab (the 
bill of materials 
will now open 
excel and begin 
calculation), 
Uncheck ‘Display 
labels at top’. OK. 
 
The Bill of 
Materials will now 
be on your 
drawing sheet, 
however it will not 
be showing all 
information.  
 
46. Move to 
position (above 
‘Parts List’) then 
double click to re-
calculate Excel 
functions.    
 
47. An Excel type 
window will open 
as shown (top left). 
All information 
should now be 
shown. To get out 
left-click the 
drawing sheet.  
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CUSTOM PROPERTIES IN A 
DRAWING 
 
To indicate that a drawing has been 
checked. This should be done in the 
drawing’s custom properties. 
 
48. Go to File>Properties>Custom 
Properties. Enter the checker’s name and 
date.  
 
Should you require to add further notes 
e.g manufacture notes to the drawing this 
can still be done by right clicking the 
drawing and pressing ‘edit sheet format’
 
49. Drawing Complete. Save Drawing 
as: Assembly_Test_Mass.slddrw 
 
50. The completed drawing should look 
like that overleaf.  
 
END. 
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